Delayed sends for emails with greater than 5k recipients
Incident Report for Retention Science
Resolved
This issue has now been resolved. All backed up emails will begin sending and all remaining emails will go out as planned.
Posted Dec 18, 2020 - 11:58 PST
Identified
We are experiencing an issue that is preventing emails from going out for list sizes greater than 5000 recipients. We have identified the issue and are currently working on a solution.
Posted Dec 18, 2020 - 11:27 PST
This incident affected: Smart Blast / Promo Blast Sends API.