Slowness navigating the website, delays sending emails..
Incident Report for Retention Science
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 12:52 PST
Investigating
We are currently investigating this issue for immediate repair
Posted Feb 01, 2024 - 09:50 PST
This incident affected: Smart Blast / Promo Blast Sends API and Transactional Sends API.