Promo Blast Send Delays
Incident Report for Retention Science
Resolved
This incident has been resolved.
Posted about 1 year ago. May 29, 2018 - 15:53 PDT
Investigating
We are currently investigating an issue causing delays in promo blast / smart blasts.
Posted about 1 year ago. May 29, 2018 - 15:42 PDT
This incident affected: Smart Blast / Promo Blast Sends API.