Shopify Imports - Service Stopped

Incident Report for Retention Science

Update

Great news! We have deployed a change that will work for most clients. We are pushing out the change carefully, monitoring for issues. Because we now have a path forward, we are downgrading this status to a "partial outage".

Clients who have a very large amount of data may have to wait a bit longer for a fix, as there are some Shopify API limitations for which we may need to find a workaround.
Posted Nov 12, 2025 - 13:55 PST

Update

Good news--we've deployed an Alpha version of the fixed code and are currently testing. Will update further once the production testing is completed.
Posted Nov 07, 2025 - 16:15 PST

Update

We are continuing to work on the broken Shopify imports issue. We have rough replacement code written for all affected API endpoints, but we are in the manual testing phase, which may take some time. Our current estimate is a production deployment by mid next week. Thank you for your patience, and please stay tuned for more updates.
Posted Oct 29, 2025 - 17:19 PDT

Update

We are continuing to work on a fix for the Shopify import issue. We are working on early versions of the new API calls that were migrated from REST endpoints to GraphQL endpoints, and things seem to be going well so far. It will take some time to finish replacing all endpoints, fix the automated tests, and do thorough manual testing.
Posted Oct 22, 2025 - 06:43 PDT

Identified

Due to changes in the Shopify API we are unable to import any data with the Retention Science/Ecommerce Pro application created for Shopify customers. We are actively working on a solution and will update the status page with more info when it is available. In the meantime, manually exporting users from Shopify to a file and importing into accounts is the most viable workaround. (users, orders, items and other data will be uploaded as soon as the application is restored.) For manual imports, please see: https://help.retentionscience.com/hc/en-us/articles/115008016767-How-to-upload-lists
For manually importing data that is not just users, please reach out to support for next steps.
Posted Oct 17, 2025 - 12:15 PDT
This incident affects: Data Imports Service.