Issue Saving Segments

Incident Report for Retention Science

Resolved

This incident has been resolved.
Posted Jul 21, 2020 - 14:41 PDT

Investigating

We are currently experiencing an issue when trying to save segments. We are in the process of identifying the source issue and will send an update once we know more.
Posted Jul 21, 2020 - 14:11 PDT
This incident affected: Filtering and Segmentation Service.